NuGet package is broken

Apr 26, 2011 at 4:44 PM

- Includes Moq.dll despite having defining a dependency on Moq package

- The version of Moq that Moq.Contrib it is built against is 4.0.812.4 but the version of Moq that it is shipped with it is 4.0.10827.0 resulting in "System.IO.FileLoadException: Could not load file or assembly 'Moq, Version=4.0.812.4, Culture=neutral, PublicKeyToken=69f491c39445e920' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference."

Coordinator
Apr 27, 2011 at 12:23 AM

We are working on a rewritten version of MoqContrib right now. As you can see, there aren't any downloads on this site yet. But if you "follow" this project you'll be the first to know when we release the new version. I can assure you that the new release will not strongly reference Moq, nor will the nuspec package include Moq directly.

Jun 13, 2013 at 6:20 AM
Any news on when you'll release a new version?

I'm a bit confusen on the versioning: The Moq.Contrib that is available on Nuget, is based on the source code found on the old GoogleGroups site, right?
The source code found here is newer, but a Nuget package still isn't available, right?

Looking forward to use the tool! It seems really cool!